【已失效】宝塔面板1G内存安装mysql5.7提示“至少需要XX兆内存”的解决办法

2019-04-05

由于普通的客户,很多选的云服务器都是1核1G的配置,选择宝塔做环境处理,安装mysql为了保证运行流程,宝塔优化限制了低配置用户安装mysql5.7,我们可以修改配置文件来实现

首先打开文件:/www/server/panel/class/panelPlugin.py

找到panelPlugin.py文件之后在142行直接注释掉就可以了

然后把这行if语句注释掉,如下:

if not self.check_cpu_limit(versionInfo['cpu_limit']): return public.returnMsg(False,'至少需要[%d]个CPU核心才能安装' % versionInfo['cpu_limit'])

#if not self.check_mem_limit(versionInfo['mem_limit']): return public.returnMsg(False,'至少需要[%dMB]内存才能安装' % versionInfo['mem_limit'])

 这样,再回到安装软件页面就可以了


帮助中心

  • Linux局域网内文件传送

    人多不足以依赖,要生存只有靠自己。深窥自己的心,而后发觉一切的奇迹在你自己。凡事皆有终结,因此,耐心是赢得成功的一种手段。

  • 【已解答】高危:Nginx后端服务指定的Header隐藏状态

    隐藏Nginx后端服务指定Header的状态: 1、打开conf/nginx.conf配置文件; 2、在http下配置proxy_hide_header项; 增加或修改为 proxy_hide_header X-Powered-By; proxy_hide_header Server;

  • 【已解答】高危:Nginx的WEB访问日志记录状态

    开启Nginx的WEB访问日志记录: 1、打开conf/nginx.conf配置文件,含主配置文件中include项包含的子配置文件; 2、在http下配置access_log项 access_log logs/host.access.log main; 3、并在主配置文件,及主配置文件下的include文件中 删除off项或配置为适当值